ALAS-2016-758


Amazon Linux AMI Security Advisory: ALAS-2016-758
Advisory Release Date: 2016-10-20 20:26 Pacific
Severity: Important
References: CVE-2016-2848 

Issue Overview:

CVE-2016-2848 bind: assertion failure triggered by a packet with malformed options

A denial of service flaw was found in the way BIND handled packets with malformed options. A remote attacker could use this flaw to make named exit unexpectedly with an assertion failure via a specially crafted DNS packet.


Affected Packages:

bind


Issue Correction:
Run yum update bind to update your system.

New Packages:
i686:
    bind-debuginfo-9.8.2-0.37.rc1.49.amzn1.i686
    bind-sdb-9.8.2-0.37.rc1.49.amzn1.i686
    bind-libs-9.8.2-0.37.rc1.49.amzn1.i686
    bind-devel-9.8.2-0.37.rc1.49.amzn1.i686
    bind-9.8.2-0.37.rc1.49.amzn1.i686
    bind-chroot-9.8.2-0.37.rc1.49.amzn1.i686
    bind-utils-9.8.2-0.37.rc1.49.amzn1.i686

src:
    bind-9.8.2-0.37.rc1.49.amzn1.src

x86_64:
    bind-debuginfo-9.8.2-0.37.rc1.49.amzn1.x86_64
    bind-9.8.2-0.37.rc1.49.amzn1.x86_64
    bind-utils-9.8.2-0.37.rc1.49.amzn1.x86_64
    bind-sdb-9.8.2-0.37.rc1.49.amzn1.x86_64
    bind-libs-9.8.2-0.37.rc1.49.amzn1.x86_64
    bind-devel-9.8.2-0.37.rc1.49.amzn1.x86_64
    bind-chroot-9.8.2-0.37.rc1.49.amzn1.x86_64