ALAS-2016-770


Amazon Linux AMI Security Advisory: ALAS-2016-770
Advisory Release Date: 2016-11-18 12:30 Pacific
Severity: Medium
References: CVE-2015-8325 

Issue Overview:

It was discovered that the OpenSSH sshd daemon fetched PAM environment settings before running the login program. In configurations with UseLogin=yes and the pam_env PAM module configured to read user environment settings, a local user could use this flaw to execute arbitrary code as root.


Affected Packages:

openssh


Issue Correction:
Run yum update openssh to update your system.

New Packages:
i686:
    openssh-clients-6.6.1p1-31.62.amzn1.i686
    openssh-debuginfo-6.6.1p1-31.62.amzn1.i686
    openssh-keycat-6.6.1p1-31.62.amzn1.i686
    openssh-ldap-6.6.1p1-31.62.amzn1.i686
    openssh-server-6.6.1p1-31.62.amzn1.i686
    pam_ssh_agent_auth-0.9.3-9.31.62.amzn1.i686
    openssh-6.6.1p1-31.62.amzn1.i686

src:
    openssh-6.6.1p1-31.62.amzn1.src

x86_64:
    pam_ssh_agent_auth-0.9.3-9.31.62.amzn1.x86_64
    openssh-debuginfo-6.6.1p1-31.62.amzn1.x86_64
    openssh-6.6.1p1-31.62.amzn1.x86_64
    openssh-ldap-6.6.1p1-31.62.amzn1.x86_64
    openssh-server-6.6.1p1-31.62.amzn1.x86_64
    openssh-keycat-6.6.1p1-31.62.amzn1.x86_64
    openssh-clients-6.6.1p1-31.62.amzn1.x86_64