ALAS-2017-785


Amazon Linux AMI Security Advisory: ALAS-2017-785
Advisory Release Date: 2017-01-19 16:30 Pacific
Severity: Medium

Issue Overview:

The following security-related issues were fixed:

Padding oracle vulnerability in Apache mod_session_crypto (CVE-2016-0736 )
DoS vulnerability in mod_auth_digest (CVE-2016-2161 )
Apache HTTP request parsing whitespace defects (CVE-2016-8743 )


Affected Packages:

httpd24


Issue Correction:
Run yum update httpd24 to update your system.

New Packages:
i686:
    mod24_ssl-2.4.25-1.68.amzn1.i686
    httpd24-2.4.25-1.68.amzn1.i686
    httpd24-debuginfo-2.4.25-1.68.amzn1.i686
    httpd24-devel-2.4.25-1.68.amzn1.i686
    mod24_session-2.4.25-1.68.amzn1.i686
    mod24_ldap-2.4.25-1.68.amzn1.i686
    mod24_proxy_html-2.4.25-1.68.amzn1.i686
    httpd24-tools-2.4.25-1.68.amzn1.i686

noarch:
    httpd24-manual-2.4.25-1.68.amzn1.noarch

src:
    httpd24-2.4.25-1.68.amzn1.src

x86_64:
    httpd24-2.4.25-1.68.amzn1.x86_64
    httpd24-debuginfo-2.4.25-1.68.amzn1.x86_64
    mod24_session-2.4.25-1.68.amzn1.x86_64
    mod24_proxy_html-2.4.25-1.68.amzn1.x86_64
    mod24_ldap-2.4.25-1.68.amzn1.x86_64
    mod24_ssl-2.4.25-1.68.amzn1.x86_64
    httpd24-devel-2.4.25-1.68.amzn1.x86_64
    httpd24-tools-2.4.25-1.68.amzn1.x86_64