ALAS-2017-815


Amazon Linux AMI Security Advisory: ALAS-2017-815
Advisory Release Date: 2017-04-17 16:36 Pacific
Severity: Medium

Issue Overview:

A denial of service flaw was found in the way the TLS/SSL protocol defined
processing of ALERT packets during a connection handshake. A remote attacker
could use this flaw to make a TLS/SSL server consume an excessive amount of CPU
and fail to accept connections form other clients. (CVE-2016-8610 )

Multiple flaws were found in the way gnutls processed OpenPGP certificates. An
attacker could create specially crafted OpenPGP certificates which, when parsed
by gnutls, would cause it to crash. (CVE-2017-5335 , CVE-2017-5336 ,
CVE-2017-5337 )


Affected Packages:

gnutls


Issue Correction:
Run yum update gnutls to update your system.

New Packages:
i686:
    gnutls-2.12.23-21.18.amzn1.i686
    gnutls-devel-2.12.23-21.18.amzn1.i686
    gnutls-guile-2.12.23-21.18.amzn1.i686
    gnutls-utils-2.12.23-21.18.amzn1.i686
    gnutls-debuginfo-2.12.23-21.18.amzn1.i686

src:
    gnutls-2.12.23-21.18.amzn1.src

x86_64:
    gnutls-guile-2.12.23-21.18.amzn1.x86_64
    gnutls-debuginfo-2.12.23-21.18.amzn1.x86_64
    gnutls-devel-2.12.23-21.18.amzn1.x86_64
    gnutls-utils-2.12.23-21.18.amzn1.x86_64
    gnutls-2.12.23-21.18.amzn1.x86_64