ALAS-2017-821


Amazon Linux AMI Security Advisory: ALAS-2017-821
Advisory Release Date: 2017-04-20 21:55 Pacific
Severity: Important
References: CVE-2017-5647 

Issue Overview:

Incorrect handling of pipelined requests when send file was used:
A bug in the handling of the pipelined requests in Apache Tomcat 9.0.0.M1 to 9.0.0.M18, 8.5.0 to 8.5.12, 8.0.0.RC1 to 8.0.42, 7.0.0 to 7.0.76, and 6.0.0 to 6.0.52, when send file was used, results in the pipelined request being lost when send file processing of the previous request completed. This could result in responses appearing to be sent for the wrong request. For example, a user agent that sent requests A, B and C could see the correct response for request A, the response for request C for request B and no response for request C. (CVE-2017-5647 )


Affected Packages:

tomcat6


Issue Correction:
Run yum update tomcat6 to update your system.

New Packages:
noarch:
    tomcat6-docs-webapp-6.0.53-1.11.amzn1.noarch
    tomcat6-webapps-6.0.53-1.11.amzn1.noarch
    tomcat6-admin-webapps-6.0.53-1.11.amzn1.noarch
    tomcat6-el-2.1-api-6.0.53-1.11.amzn1.noarch
    tomcat6-servlet-2.5-api-6.0.53-1.11.amzn1.noarch
    tomcat6-jsp-2.1-api-6.0.53-1.11.amzn1.noarch
    tomcat6-lib-6.0.53-1.11.amzn1.noarch
    tomcat6-6.0.53-1.11.amzn1.noarch
    tomcat6-javadoc-6.0.53-1.11.amzn1.noarch

src:
    tomcat6-6.0.53-1.11.amzn1.src