ALAS-2017-825


Amazon Linux AMI Security Advisory: ALAS-2017-825
Advisory Release Date: 2017-04-27 19:52 Pacific
Severity: Critical

Issue Overview:

An out-of-bounds write flaw was found in the way NSS performed certain Base64-decoding operations. An attacker could use this flaw to create a specially crafted certificate which, when parsed by NSS, could cause it to crash or execute arbitrary code, using the permissions of the user running an application compiled against the NSS library. (CVE-2017-5461 )

Upstream acknowledges Ronald Crane as the original reporter.


Affected Packages:

nss,nss-util


Issue Correction:
Run yum update nss to update your system.
Run yum update nss-util to update your system.

New Packages:
i686:
    nss-util-debuginfo-3.28.4-1.0.52.amzn1.i686
    nss-util-3.28.4-1.0.52.amzn1.i686
    nss-util-devel-3.28.4-1.0.52.amzn1.i686
    nss-3.28.4-1.0.78.amzn1.i686
    nss-pkcs11-devel-3.28.4-1.0.78.amzn1.i686
    nss-debuginfo-3.28.4-1.0.78.amzn1.i686
    nss-devel-3.28.4-1.0.78.amzn1.i686
    nss-tools-3.28.4-1.0.78.amzn1.i686
    nss-sysinit-3.28.4-1.0.78.amzn1.i686

src:
    nss-util-3.28.4-1.0.52.amzn1.src
    nss-3.28.4-1.0.78.amzn1.src

x86_64:
    nss-util-3.28.4-1.0.52.amzn1.x86_64
    nss-util-devel-3.28.4-1.0.52.amzn1.x86_64
    nss-util-debuginfo-3.28.4-1.0.52.amzn1.x86_64
    nss-sysinit-3.28.4-1.0.78.amzn1.x86_64
    nss-debuginfo-3.28.4-1.0.78.amzn1.x86_64
    nss-pkcs11-devel-3.28.4-1.0.78.amzn1.x86_64
    nss-tools-3.28.4-1.0.78.amzn1.x86_64
    nss-devel-3.28.4-1.0.78.amzn1.x86_64
    nss-3.28.4-1.0.78.amzn1.x86_64