ALAS-2017-832


Amazon Linux AMI Security Advisory: ALAS-2017-832
Advisory Release Date: 2017-05-31 21:40 Pacific
Severity: Important
References: CVE-2016-10229 

Issue Overview:

Unsafe second checksum calculation in udp.c:
The Linux kernel allows remote attackers to execute arbitrary code via UDP traffic that triggers an unsafe second checksum calculation during execution of a recv system call with the MSG_PEEK flag. This may create a kernel panic or memory corruption leading to privilege escalation. (CVE-2016-10229 )


Affected Packages:

kernel


Issue Correction:
Run yum update kernel to update your system.

New Packages:
i686:
    perf-debuginfo-4.9.17-8.31.amzn1.i686
    perf-4.9.17-8.31.amzn1.i686
    kernel-tools-debuginfo-4.9.17-8.31.amzn1.i686
    kernel-tools-4.9.17-8.31.amzn1.i686
    kernel-4.9.17-8.31.amzn1.i686
    kernel-headers-4.9.17-8.31.amzn1.i686
    kernel-debuginfo-common-i686-4.9.17-8.31.amzn1.i686
    kernel-debuginfo-4.9.17-8.31.amzn1.i686
    kernel-devel-4.9.17-8.31.amzn1.i686
    kernel-tools-devel-4.9.17-8.31.amzn1.i686

noarch:
    kernel-doc-4.9.17-8.31.amzn1.noarch

src:
    kernel-4.9.17-8.31.amzn1.src

x86_64:
    kernel-headers-4.9.17-8.31.amzn1.x86_64
    perf-debuginfo-4.9.17-8.31.amzn1.x86_64
    perf-4.9.17-8.31.amzn1.x86_64
    kernel-4.9.17-8.31.amzn1.x86_64
    kernel-debuginfo-4.9.17-8.31.amzn1.x86_64
    kernel-tools-devel-4.9.17-8.31.amzn1.x86_64
    kernel-tools-debuginfo-4.9.17-8.31.amzn1.x86_64
    kernel-debuginfo-common-x86_64-4.9.17-8.31.amzn1.x86_64
    kernel-devel-4.9.17-8.31.amzn1.x86_64
    kernel-tools-4.9.17-8.31.amzn1.x86_64