ALAS-2017-836


Amazon Linux AMI Security Advisory: ALAS-2017-836
Advisory Release Date: 2017-07-25 18:15 Pacific
Severity: Important

Issue Overview:

Multiple flaws were found in the way JasPer decoded JPEG 2000 image files. A
specially crafted file could cause an application using JasPer to crash or,
possibly, execute arbitrary code. ( CVE-2016-8654 , CVE-2016-9560 , CVE-2016-10249 ,
CVE-2015-5203 , CVE-2015-5221 , CVE-2016-1577 , CVE-2016-8690 , CVE-2016-8693 ,
CVE-2016-8884 , CVE-2016-8885 , CVE-2016-9262 , CVE-2016-9591 )

Multiple flaws were found in the way JasPer decoded JPEG 2000 image files. A
specially crafted file could cause an application using JasPer to crash.
(CVE-2016-1867 , CVE-2016-2089 , CVE-2016-2116 , CVE-2016-8691 , CVE-2016-8692 ,
CVE-2016-8883 , CVE-2016-9387 , CVE-2016-9388 , CVE-2016-9389 , CVE-2016-9390 ,
CVE-2016-9391 , CVE-2016-9392 , CVE-2016-9393 , CVE-2016-9394 , CVE-2016-9583 ,
CVE-2016-9600 , CVE-2016-10248 , CVE-2016-10251 )


Affected Packages:

jasper


Issue Correction:
Run yum update jasper to update your system.

New Packages:
i686:
    jasper-devel-1.900.1-21.9.amzn1.i686
    jasper-utils-1.900.1-21.9.amzn1.i686
    jasper-1.900.1-21.9.amzn1.i686
    jasper-libs-1.900.1-21.9.amzn1.i686
    jasper-debuginfo-1.900.1-21.9.amzn1.i686

src:
    jasper-1.900.1-21.9.amzn1.src

x86_64:
    jasper-debuginfo-1.900.1-21.9.amzn1.x86_64
    jasper-libs-1.900.1-21.9.amzn1.x86_64
    jasper-1.900.1-21.9.amzn1.x86_64
    jasper-devel-1.900.1-21.9.amzn1.x86_64
    jasper-utils-1.900.1-21.9.amzn1.x86_64