ALAS-2017-837


Amazon Linux AMI Security Advisory: ALAS-2017-837
Advisory Release Date: 2017-06-06 22:44 Pacific
Severity: Important

Issue Overview:

It was found that ghostscript did not properly validate the parameters passed
to the .rsdparams and .eqproc functions. During its execution, a specially
crafted PostScript document could execute code in the context of the ghostscript
process, bypassing the -dSAFER protection. (CVE-2017-8291 )


Affected Packages:

ghostscript


Issue Correction:
Run yum update ghostscript to update your system.

New Packages:
i686:
    ghostscript-8.70-23.25.amzn1.i686
    ghostscript-debuginfo-8.70-23.25.amzn1.i686
    ghostscript-doc-8.70-23.25.amzn1.i686
    ghostscript-devel-8.70-23.25.amzn1.i686

src:
    ghostscript-8.70-23.25.amzn1.src

x86_64:
    ghostscript-doc-8.70-23.25.amzn1.x86_64
    ghostscript-devel-8.70-23.25.amzn1.x86_64
    ghostscript-debuginfo-8.70-23.25.amzn1.x86_64
    ghostscript-8.70-23.25.amzn1.x86_64