ALAS-2017-842


Amazon Linux AMI Security Advisory: ALAS-2017-842
Advisory Release Date: 2017-06-06 22:51 Pacific
Severity: Medium
References: CVE-2017-8386 

Issue Overview:

Escape out of git-shell
A flaw was found in the way git-shell handled command-line options for the restricted set of git-shell commands. A remote authenticated attacker could use this flaw to bypass git-shell restrictions, to view and manipulate files, by abusing the instance of the less command launched using crafted command-line options. (CVE-2017-8386 )


Affected Packages:

git


Issue Correction:
Run yum update git to update your system.

New Packages:
i686:
    git-daemon-2.7.5-1.49.amzn1.i686
    git-2.7.5-1.49.amzn1.i686
    git-svn-2.7.5-1.49.amzn1.i686
    git-debuginfo-2.7.5-1.49.amzn1.i686

noarch:
    perl-Git-SVN-2.7.5-1.49.amzn1.noarch
    git-cvs-2.7.5-1.49.amzn1.noarch
    perl-Git-2.7.5-1.49.amzn1.noarch
    git-all-2.7.5-1.49.amzn1.noarch
    git-p4-2.7.5-1.49.amzn1.noarch
    gitweb-2.7.5-1.49.amzn1.noarch
    emacs-git-2.7.5-1.49.amzn1.noarch
    git-hg-2.7.5-1.49.amzn1.noarch
    emacs-git-el-2.7.5-1.49.amzn1.noarch
    git-email-2.7.5-1.49.amzn1.noarch
    git-bzr-2.7.5-1.49.amzn1.noarch

src:
    git-2.7.5-1.49.amzn1.src

x86_64:
    git-svn-2.7.5-1.49.amzn1.x86_64
    git-debuginfo-2.7.5-1.49.amzn1.x86_64
    git-2.7.5-1.49.amzn1.x86_64
    git-daemon-2.7.5-1.49.amzn1.x86_64