ALAS-2017-864


Amazon Linux AMI Security Advisory: ALAS-2017-864
Advisory Release Date: 2017-08-04 00:45 Pacific
Severity: Medium
References: CVE-2016-6129 

Issue Overview:

possible OP-TEE Bleichenbacher attack:
The rsa_verify_hash_ex function in rsa_verify_hash.c in LibTomCrypt, as used in OP-TEE before 2.2.0, does not validate that the message length is equal to the ASN.1 encoded data length, which makes it easier for remote attackers to forge RSA signatures or public certificates by leveraging a Bleichenbacher signature forgery attack. (CVE-2016-6129 )


Affected Packages:

libtommath,libtomcrypt


Issue Correction:
Run yum update libtommath to update your system.
Run yum update libtomcrypt to update your system.

New Packages:
i686:
    libtomcrypt-1.17-25.4.amzn1.i686
    libtomcrypt-debuginfo-1.17-25.4.amzn1.i686
    libtomcrypt-devel-1.17-25.4.amzn1.i686
    libtommath-debuginfo-0.42.0-5.3.3.amzn1.i686
    libtommath-0.42.0-5.3.3.amzn1.i686
    libtommath-devel-0.42.0-5.3.3.amzn1.i686

src:
    libtomcrypt-1.17-25.4.amzn1.src
    libtommath-0.42.0-5.3.3.amzn1.src

x86_64:
    libtomcrypt-1.17-25.4.amzn1.x86_64
    libtomcrypt-debuginfo-1.17-25.4.amzn1.x86_64
    libtomcrypt-devel-1.17-25.4.amzn1.x86_64
    libtommath-debuginfo-0.42.0-5.3.3.amzn1.x86_64
    libtommath-0.42.0-5.3.3.amzn1.x86_64
    libtommath-devel-0.42.0-5.3.3.amzn1.x86_64