ALAS-2017-868


Amazon Linux AMI Security Advisory: ALAS-2017-868
Advisory Release Date: 2017-10-26 23:11 Pacific
Severity: Critical

Issue Overview:

Exploitable memory corruption due to UFO to non-UFO path switch (CVE-2017-1000112 )

heap out-of-bounds in AF_PACKET sockets (CVE-2017-1000111 )

The mq_notify function in the Linux kernel does not set the sock pointer to NULL upon entry into the retry logic. During a user-space close of a Netlink socket, it allows attackers to possibly cause a situation where a value may be used after being freed (use-after-free) which may lead to memory corruption or other unspecified other impact. (CVE-2017-11176 )


Affected Packages:

kernel


Issue Correction:
Run yum update kernel to update your system.

New Packages:
i686:
    kernel-tools-debuginfo-4.9.38-16.35.amzn1.i686
    kernel-tools-4.9.38-16.35.amzn1.i686
    kernel-debuginfo-4.9.38-16.35.amzn1.i686
    kernel-debuginfo-common-i686-4.9.38-16.35.amzn1.i686
    kernel-tools-devel-4.9.38-16.35.amzn1.i686
    kernel-devel-4.9.38-16.35.amzn1.i686
    kernel-4.9.38-16.35.amzn1.i686
    perf-debuginfo-4.9.38-16.35.amzn1.i686
    perf-4.9.38-16.35.amzn1.i686
    kernel-headers-4.9.38-16.35.amzn1.i686

noarch:
    kernel-doc-4.9.38-16.35.amzn1.noarch

src:
    kernel-4.9.38-16.35.amzn1.src

x86_64:
    perf-debuginfo-4.9.38-16.35.amzn1.x86_64
    kernel-tools-4.9.38-16.35.amzn1.x86_64
    perf-4.9.38-16.35.amzn1.x86_64
    kernel-devel-4.9.38-16.35.amzn1.x86_64
    kernel-tools-devel-4.9.38-16.35.amzn1.x86_64
    kernel-headers-4.9.38-16.35.amzn1.x86_64
    kernel-debuginfo-common-x86_64-4.9.38-16.35.amzn1.x86_64
    kernel-debuginfo-4.9.38-16.35.amzn1.x86_64
    kernel-4.9.38-16.35.amzn1.x86_64
    kernel-tools-debuginfo-4.9.38-16.35.amzn1.x86_64