ALAS-2017-880


Amazon Linux AMI Security Advisory: ALAS-2017-880
Advisory Release Date: 2017-08-31 23:06 Pacific
Severity: Medium
References: CVE-2016-7798 

Issue Overview:

IV Reuse in GCM Mode:
The openssl gem for Ruby uses the same initialization vector (IV) in GCM Mode (aes-*-gcm) when the IV is set before the key, which makes it easier for context-dependent attackers to bypass the encryption protection mechanism. (CVE-2016-7798 )


Affected Packages:

ruby23


Issue Correction:
Run yum update ruby23 to update your system.

New Packages:
i686:
    ruby23-debuginfo-2.3.4-1.15.amzn1.i686
    ruby23-devel-2.3.4-1.15.amzn1.i686
    rubygem23-psych-2.1.0-1.15.amzn1.i686
    rubygem23-io-console-0.4.5-1.15.amzn1.i686
    ruby23-2.3.4-1.15.amzn1.i686
    rubygem23-bigdecimal-1.2.8-1.15.amzn1.i686
    ruby23-libs-2.3.4-1.15.amzn1.i686

noarch:
    ruby23-doc-2.3.4-1.15.amzn1.noarch
    rubygems23-devel-2.5.2-1.15.amzn1.noarch
    rubygem23-did_you_mean-1.0.0-1.15.amzn1.noarch
    ruby23-irb-2.3.4-1.15.amzn1.noarch
    rubygems23-2.5.2-1.15.amzn1.noarch

src:
    ruby23-2.3.4-1.15.amzn1.src

x86_64:
    ruby23-2.3.4-1.15.amzn1.x86_64
    rubygem23-io-console-0.4.5-1.15.amzn1.x86_64
    ruby23-devel-2.3.4-1.15.amzn1.x86_64
    rubygem23-bigdecimal-1.2.8-1.15.amzn1.x86_64
    ruby23-debuginfo-2.3.4-1.15.amzn1.x86_64
    ruby23-libs-2.3.4-1.15.amzn1.x86_64
    rubygem23-psych-2.1.0-1.15.amzn1.x86_64