ALAS-2017-887


Amazon Linux AMI Security Advisory: ALAS-2017-887
Advisory Release Date: 2017-08-31 23:29 Pacific
Severity: Medium

Issue Overview:

Server: Charsets unspecified vulnerability (CPU Jul 2017)
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Charsets). Supported versions that are affected are 5.5.56 and earlier, 5.6.36 and earlier and 5.7.18 and earlier. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. (CVE-2017-3648 )

Server: DML unspecified vulnerability (CPU Jul 2017)
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: DML). Supported versions that are affected are 5.5.56 and earlier, 5.6.36 and earlier and 5.7.18 and earlier. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. (CVE-2017-3641 )

Client programs unspecified vulnerability (CPU Jul 2017)
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Client programs). Supported versions that are affected are 5.5.56 and earlier and 5.6.36 and earlier. Easily exploitable vulnerability allows low privileged attacker with logon to the infrastructure where MySQL Server executes to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data as well as unauthorized read access to a subset of MySQL Server accessible data and unauthorized ability to cause a partial denial of service (partial DOS) of MySQL Server. (CVE-2017-3636 )

C API unspecified vulnerability (CPU Jul 2017):
Vulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/C). Supported versions that are affected are 6.1.10 and earlier. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Connectors. Note: The documentation has also been updated for the correct way to use mysql_stmt_close(). Please see: https://dev.mysql.com/doc/refman/5.7/en/mysql-stmt-execute.html, https://dev.mysql.com/doc/refman/5.7/en/mysql-stmt-fetch.html, https://dev.mysql.com/doc/refman/5.7/en/mysql-stmt-close.html, https://dev.mysql.com/doc/refman/5.7/en/mysql-stmt-error.html, https://dev.mysql.com/doc/refman/5.7/en/mysql-stmt-errno.html, and https://dev.mysql.com/doc/refman/5.7/en/mysql-stmt-sqlstate.html.(CVE-2017-3635 )


Client mysqldump unspecified vulnerability (CPU Jul 2017):
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Client mysqldump). Supported versions that are affected are 5.5.56 and earlier, 5.6.36 and earlier and 5.7.18 and earlier. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data. (CVE-2017-3651 )

Server: DDL unspecified vulnerability (CPU Jul 2017):
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: DDL). Supported versions that are affected are 5.5.56 and earlier, 5.6.36 and earlier and 5.7.18 and earlier. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data. (CVE-2017-3653 )

Server: DDL unspecified vulnerability (CPU Jul 2017):
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: DDL). Supported versions that are affected are 5.5.56 and earlier, 5.6.36 and earlier and 5.7.18 and earlier. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data as well as unauthorized read access to a subset of MySQL Server accessible data. (CVE-2017-3652 )


Affected Packages:

mysql55


Issue Correction:
Run yum update mysql55 to update your system.

New Packages:
i686:
    mysql55-bench-5.5.57-1.18.amzn1.i686
    mysql55-test-5.5.57-1.18.amzn1.i686
    mysql55-embedded-devel-5.5.57-1.18.amzn1.i686
    mysql55-devel-5.5.57-1.18.amzn1.i686
    mysql55-server-5.5.57-1.18.amzn1.i686
    mysql55-debuginfo-5.5.57-1.18.amzn1.i686
    mysql55-libs-5.5.57-1.18.amzn1.i686
    mysql55-embedded-5.5.57-1.18.amzn1.i686
    mysql55-5.5.57-1.18.amzn1.i686
    mysql-config-5.5.57-1.18.amzn1.i686

src:
    mysql55-5.5.57-1.18.amzn1.src

x86_64:
    mysql55-debuginfo-5.5.57-1.18.amzn1.x86_64
    mysql55-libs-5.5.57-1.18.amzn1.x86_64
    mysql55-test-5.5.57-1.18.amzn1.x86_64
    mysql55-5.5.57-1.18.amzn1.x86_64
    mysql55-embedded-devel-5.5.57-1.18.amzn1.x86_64
    mysql-config-5.5.57-1.18.amzn1.x86_64
    mysql55-embedded-5.5.57-1.18.amzn1.x86_64
    mysql55-bench-5.5.57-1.18.amzn1.x86_64
    mysql55-server-5.5.57-1.18.amzn1.x86_64
    mysql55-devel-5.5.57-1.18.amzn1.x86_64