ALAS-2017-892


Amazon Linux AMI Security Advisory: ALAS-2017-892
Advisory Release Date: 2017-09-14 22:21 Pacific
Severity: Important

Issue Overview:

A NULL pointer dereference flaw was found in the httpd's mod_ssl module. A remote attacker could use this flaw to cause an httpd child process to crash if another module used by httpd called a certain API function during the processing of an HTTPS request. (CVE-2017-3169 )

It was discovered that the use of httpd's ap_get_basic_auth_pw() API function outside of the authentication phase could lead to authentication bypass. A remote attacker could possibly use this flaw to bypass required authentication if the API was used incorrectly by one of the modules used by httpd. (CVE-2017-3167 )

A buffer over-read flaw was found in the httpd's mod_mime module. A user permitted to modify httpd's MIME configuration could use this flaw to cause httpd child process to crash. (CVE-2017-7679 )

It was discovered that the httpd's mod_auth_digest module did not properly initialize memory before using it when processing certain headers related to digest authentication. A remote attacker could possibly use this flaw to disclose potentially sensitive information or cause httpd child process to crash by sending specially crafted requests to a server. (CVE-2017-9788 )


Affected Packages:

httpd


Issue Correction:
Run yum update httpd to update your system.

New Packages:
i686:
    httpd-tools-2.2.34-1.12.amzn1.i686
    mod_ssl-2.2.34-1.12.amzn1.i686
    httpd-debuginfo-2.2.34-1.12.amzn1.i686
    httpd-devel-2.2.34-1.12.amzn1.i686
    httpd-2.2.34-1.12.amzn1.i686

noarch:
    httpd-manual-2.2.34-1.12.amzn1.noarch

src:
    httpd-2.2.34-1.12.amzn1.src

x86_64:
    mod_ssl-2.2.34-1.12.amzn1.x86_64
    httpd-devel-2.2.34-1.12.amzn1.x86_64
    httpd-debuginfo-2.2.34-1.12.amzn1.x86_64
    httpd-tools-2.2.34-1.12.amzn1.x86_64
    httpd-2.2.34-1.12.amzn1.x86_64