ALAS-2017-894


Amazon Linux AMI Security Advisory: ALAS-2017-894
Advisory Release Date: 2017-09-14 22:22 Pacific
Severity: Low
References: CVE-2017-7529 

Issue Overview:

A flaw within the processing of ranged HTTP requests has been discovered in the range filter module of nginx. A remote attacker could possibly exploit this flaw to disclose parts of the cache file header, or, if used in combination with third party modules, disclose potentially sensitive memory by sending specially crafted HTTP requests. (CVE-2017-7529 )


Affected Packages:

nginx


Issue Correction:
Run yum update nginx to update your system.

New Packages:
i686:
    nginx-all-modules-1.12.1-1.32.amzn1.i686
    nginx-1.12.1-1.32.amzn1.i686
    nginx-mod-http-geoip-1.12.1-1.32.amzn1.i686
    nginx-mod-mail-1.12.1-1.32.amzn1.i686
    nginx-debuginfo-1.12.1-1.32.amzn1.i686
    nginx-mod-http-xslt-filter-1.12.1-1.32.amzn1.i686
    nginx-mod-http-perl-1.12.1-1.32.amzn1.i686
    nginx-mod-stream-1.12.1-1.32.amzn1.i686
    nginx-mod-http-image-filter-1.12.1-1.32.amzn1.i686

src:
    nginx-1.12.1-1.32.amzn1.src

x86_64:
    nginx-all-modules-1.12.1-1.32.amzn1.x86_64
    nginx-1.12.1-1.32.amzn1.x86_64
    nginx-mod-http-geoip-1.12.1-1.32.amzn1.x86_64
    nginx-debuginfo-1.12.1-1.32.amzn1.x86_64
    nginx-mod-mail-1.12.1-1.32.amzn1.x86_64
    nginx-mod-stream-1.12.1-1.32.amzn1.x86_64
    nginx-mod-http-xslt-filter-1.12.1-1.32.amzn1.x86_64
    nginx-mod-http-image-filter-1.12.1-1.32.amzn1.x86_64
    nginx-mod-http-perl-1.12.1-1.32.amzn1.x86_64