ALAS-2017-905


Amazon Linux AMI Security Advisory: ALAS-2017-905
Advisory Release Date: 2017-10-02 21:44 Pacific
Severity: Medium
References: CVE-2017-7551 

Issue Overview:

Password brute-force possible for locked account due to different return codes:
A flaw was found in the way 389-ds-base handled authentication attempts against locked accounts. A remote attacker could potentially use this flaw to continue password brute-forcing attacks against LDAP accounts, thereby bypassing the protection offered by the directory server's password lockout policy. (CVE-2017-7551 )


Affected Packages:

389-ds-base


Issue Correction:
Run yum update 389-ds-base to update your system.

New Packages:
i686:
    389-ds-base-libs-1.3.6.1-19.51.amzn1.i686
    389-ds-base-devel-1.3.6.1-19.51.amzn1.i686
    389-ds-base-1.3.6.1-19.51.amzn1.i686
    389-ds-base-snmp-1.3.6.1-19.51.amzn1.i686
    389-ds-base-debuginfo-1.3.6.1-19.51.amzn1.i686

src:
    389-ds-base-1.3.6.1-19.51.amzn1.src

x86_64:
    389-ds-base-libs-1.3.6.1-19.51.amzn1.x86_64
    389-ds-base-snmp-1.3.6.1-19.51.amzn1.x86_64
    389-ds-base-devel-1.3.6.1-19.51.amzn1.x86_64
    389-ds-base-debuginfo-1.3.6.1-19.51.amzn1.x86_64
    389-ds-base-1.3.6.1-19.51.amzn1.x86_64