ALAS-2018-1010


Amazon Linux AMI Security Advisory: ALAS-2018-1010
Advisory Release Date: 2018-09-06 21:59 Pacific
Severity: Medium

Issue Overview:

A denial of service flaw was found in MIT Kerberos krb5kdc service. An authenticated attacker could use this flaw to cause krb5kdc to exit with an assertion failure by making an invalid S4U2Self or S4U2Proxy request.(CVE-2017-11368 )

An authentication bypass flaw was found in the way krb5's certauth interface handled the validation of client certificates. A remote attacker able to communicate with the KDC could potentially use this flaw to impersonate arbitrary principals under rare and erroneous circumstances.(CVE-2017-7562 )


Affected Packages:

krb5


Issue Correction:
Run yum update krb5 to update your system.

New Packages:
i686:
    krb5-debuginfo-1.15.1-19.43.amzn1.i686
    krb5-workstation-1.15.1-19.43.amzn1.i686
    krb5-devel-1.15.1-19.43.amzn1.i686
    krb5-pkinit-openssl-1.15.1-19.43.amzn1.i686
    libkadm5-1.15.1-19.43.amzn1.i686
    krb5-libs-1.15.1-19.43.amzn1.i686
    krb5-server-1.15.1-19.43.amzn1.i686
    krb5-server-ldap-1.15.1-19.43.amzn1.i686

src:
    krb5-1.15.1-19.43.amzn1.src

x86_64:
    krb5-devel-1.15.1-19.43.amzn1.x86_64
    krb5-server-1.15.1-19.43.amzn1.x86_64
    krb5-debuginfo-1.15.1-19.43.amzn1.x86_64
    krb5-workstation-1.15.1-19.43.amzn1.x86_64
    krb5-libs-1.15.1-19.43.amzn1.x86_64
    krb5-pkinit-openssl-1.15.1-19.43.amzn1.x86_64
    libkadm5-1.15.1-19.43.amzn1.x86_64
    krb5-server-ldap-1.15.1-19.43.amzn1.x86_64