ALAS-2018-1018


Amazon Linux AMI Security Advisory: ALAS-2018-1018
Advisory Release Date: 2018-05-10 17:51 Pacific
Severity: Low
References: CVE-2017-15906 

Issue Overview:

Improper write operations in readonly mode allow for zero-length file creation
The process_open function in sftp-server.c in OpenSSH before 7.6 does not properly prevent write operations in readonly mode, which allows attackers to create zero-length files.(CVE-2017-15906 )


Affected Packages:

openssh


Issue Correction:
Run yum update openssh to update your system.

New Packages:
i686:
    openssh-7.4p1-16.69.amzn1.i686
    openssh-keycat-7.4p1-16.69.amzn1.i686
    openssh-cavs-7.4p1-16.69.amzn1.i686
    pam_ssh_agent_auth-0.10.3-2.16.69.amzn1.i686
    openssh-ldap-7.4p1-16.69.amzn1.i686
    openssh-clients-7.4p1-16.69.amzn1.i686
    openssh-debuginfo-7.4p1-16.69.amzn1.i686
    openssh-server-7.4p1-16.69.amzn1.i686

src:
    openssh-7.4p1-16.69.amzn1.src

x86_64:
    openssh-cavs-7.4p1-16.69.amzn1.x86_64
    openssh-7.4p1-16.69.amzn1.x86_64
    pam_ssh_agent_auth-0.10.3-2.16.69.amzn1.x86_64
    openssh-keycat-7.4p1-16.69.amzn1.x86_64
    openssh-ldap-7.4p1-16.69.amzn1.x86_64
    openssh-clients-7.4p1-16.69.amzn1.x86_64
    openssh-debuginfo-7.4p1-16.69.amzn1.x86_64
    openssh-server-7.4p1-16.69.amzn1.x86_64