ALAS-2018-1025


Amazon Linux AMI Security Advisory: ALAS-2018-1025
Advisory Release Date: 2018-07-24 21:04 Pacific
Severity: Low
References: CVE-2018-9234 

Issue Overview:

Unenforced configuration allows for apparently valid certifications actually signed by signing subkeys:
GnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an offline master Certify key, which results in apparently valid certifications that occurred only with access to a signing subkey. (CVE-2018-9234 )


Affected Packages:

gnupg2


Issue Correction:
Run yum update gnupg2 to update your system.

New Packages:
i686:
    gnupg2-smime-2.0.28-2.32.amzn1.i686
    gnupg2-debuginfo-2.0.28-2.32.amzn1.i686
    gnupg2-2.0.28-2.32.amzn1.i686

src:
    gnupg2-2.0.28-2.32.amzn1.src

x86_64:
    gnupg2-smime-2.0.28-2.32.amzn1.x86_64
    gnupg2-debuginfo-2.0.28-2.32.amzn1.x86_64
    gnupg2-2.0.28-2.32.amzn1.x86_64