ALAS-2018-1057


Amazon Linux AMI Security Advisory: ALAS-2018-1057
Advisory Release Date: 2018-08-09 16:13 Pacific
Severity: Important
References: CVE-2018-10897 

Issue Overview:

A directory traversal issue was found in reposync, a part of yum-utils, where reposync fails to sanitize paths in remote repository configuration files. If an attacker controls a repository, they may be able to copy files outside of the destination directory on the targeted system via path traversal. If reposync is running with heightened privileges on a targeted system, this flaw could potentially result in system compromise via the overwriting of critical system files.(CVE-2018-10897 )


Affected Packages:

yum-utils


Issue Correction:
Run yum update yum-utils to update your system.

New Packages:
noarch:
    yum-updateonboot-1.1.31-46.30.amzn1.noarch
    yum-plugin-ps-1.1.31-46.30.amzn1.noarch
    yum-plugin-rpm-warm-cache-1.1.31-46.30.amzn1.noarch
    yum-plugin-tmprepo-1.1.31-46.30.amzn1.noarch
    yum-plugin-ovl-1.1.31-46.30.amzn1.noarch
    yum-plugin-fastestmirror-1.1.31-46.30.amzn1.noarch
    yum-plugin-auto-update-debug-info-1.1.31-46.30.amzn1.noarch
    yum-plugin-filter-data-1.1.31-46.30.amzn1.noarch
    yum-plugin-versionlock-1.1.31-46.30.amzn1.noarch
    yum-plugin-remove-with-leaves-1.1.31-46.30.amzn1.noarch
    yum-plugin-pre-transaction-actions-1.1.31-46.30.amzn1.noarch
    yum-plugin-show-leaves-1.1.31-46.30.amzn1.noarch
    yum-plugin-tsflags-1.1.31-46.30.amzn1.noarch
    yum-utils-1.1.31-46.30.amzn1.noarch
    yum-plugin-local-1.1.31-46.30.amzn1.noarch
    yum-plugin-upgrade-helper-1.1.31-46.30.amzn1.noarch
    yum-plugin-refresh-updatesd-1.1.31-46.30.amzn1.noarch
    yum-plugin-changelog-1.1.31-46.30.amzn1.noarch
    yum-plugin-protectbase-1.1.31-46.30.amzn1.noarch
    yum-plugin-copr-1.1.31-46.30.amzn1.noarch
    yum-plugin-aliases-1.1.31-46.30.amzn1.noarch
    yum-plugin-merge-conf-1.1.31-46.30.amzn1.noarch
    yum-plugin-keys-1.1.31-46.30.amzn1.noarch
    yum-plugin-post-transaction-actions-1.1.31-46.30.amzn1.noarch
    yum-plugin-priorities-1.1.31-46.30.amzn1.noarch
    yum-plugin-verify-1.1.31-46.30.amzn1.noarch
    yum-plugin-puppetverify-1.1.31-46.30.amzn1.noarch
    yum-plugin-list-data-1.1.31-46.30.amzn1.noarch
    yum-NetworkManager-dispatcher-1.1.31-46.30.amzn1.noarch
    yum-plugin-fs-snapshot-1.1.31-46.30.amzn1.noarch

src:
    yum-utils-1.1.31-46.30.amzn1.src