ALAS-2018-1075


Amazon Linux AMI Security Advisory: ALAS-2018-1075
Advisory Release Date: 2018-09-06 22:02 Pacific
Severity: Low
References: CVE-2018-15473 

Issue Overview:

OpenSSH is prone to a user enumeration vulnerability due to not delaying bailout for an invalid authenticating user until after the packet containing the request has been fully parsed, related to auth2-gss.c, auth2-hostbased.c, and auth2-pubkey.c.(CVE-2018-15473 )


Affected Packages:

openssh


Issue Correction:
Run yum update openssh to update your system.

New Packages:
i686:
    openssh-server-7.4p1-16.71.amzn1.i686
    openssh-clients-7.4p1-16.71.amzn1.i686
    openssh-keycat-7.4p1-16.71.amzn1.i686
    openssh-cavs-7.4p1-16.71.amzn1.i686
    openssh-7.4p1-16.71.amzn1.i686
    pam_ssh_agent_auth-0.10.3-2.16.71.amzn1.i686
    openssh-ldap-7.4p1-16.71.amzn1.i686
    openssh-debuginfo-7.4p1-16.71.amzn1.i686

src:
    openssh-7.4p1-16.71.amzn1.src

x86_64:
    openssh-keycat-7.4p1-16.71.amzn1.x86_64
    openssh-debuginfo-7.4p1-16.71.amzn1.x86_64
    openssh-server-7.4p1-16.71.amzn1.x86_64
    openssh-cavs-7.4p1-16.71.amzn1.x86_64
    openssh-clients-7.4p1-16.71.amzn1.x86_64
    openssh-ldap-7.4p1-16.71.amzn1.x86_64
    openssh-7.4p1-16.71.amzn1.x86_64
    pam_ssh_agent_auth-0.10.3-2.16.71.amzn1.x86_64