ALAS-2018-1076


Amazon Linux AMI Security Advisory: ALAS-2018-1076
Advisory Release Date: 2018-09-06 22:03 Pacific
Severity: Important
References: CVE-2016-3191 

Issue Overview:

The compile_branch function in pcre_compile.c in PCRE 8.x and pcre2_compile.c in PCRE2 mishandles patterns containing an (*ACCEPT) substring in conjunction with nested parentheses, which allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow) via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror, aka ZDI-CAN-3542.(CVE-2016-3191 )


Affected Packages:

pcre


Issue Correction:
Run yum update pcre to update your system.

New Packages:
i686:
    pcre-static-8.21-7.8.amzn1.i686
    pcre-debuginfo-8.21-7.8.amzn1.i686
    pcre-tools-8.21-7.8.amzn1.i686
    pcre-devel-8.21-7.8.amzn1.i686
    pcre-8.21-7.8.amzn1.i686

src:
    pcre-8.21-7.8.amzn1.src

x86_64:
    pcre-8.21-7.8.amzn1.x86_64
    pcre-tools-8.21-7.8.amzn1.x86_64
    pcre-debuginfo-8.21-7.8.amzn1.x86_64
    pcre-devel-8.21-7.8.amzn1.x86_64
    pcre-static-8.21-7.8.amzn1.x86_64