ALAS-2018-1093


Amazon Linux AMI Security Advisory: ALAS-2018-1093
Advisory Release Date: 2018-10-18 22:23 Pacific
Severity: Important
References: CVE-2018-17456 

Issue Overview:

Git before 2.14.5, allows remote code execution during processing of a recursive "git clone" of a superproject if a .gitmodules file has a URL field beginning with a '-' character.(CVE-2018-17456 )


Affected Packages:

git


Issue Correction:
Run yum update git to update your system.

New Packages:
i686:
    git-debuginfo-2.14.5-1.59.amzn1.i686
    git-svn-2.14.5-1.59.amzn1.i686
    git-daemon-2.14.5-1.59.amzn1.i686
    git-2.14.5-1.59.amzn1.i686

noarch:
    git-p4-2.14.5-1.59.amzn1.noarch
    git-email-2.14.5-1.59.amzn1.noarch
    perl-Git-SVN-2.14.5-1.59.amzn1.noarch
    git-hg-2.14.5-1.59.amzn1.noarch
    emacs-git-2.14.5-1.59.amzn1.noarch
    emacs-git-el-2.14.5-1.59.amzn1.noarch
    git-all-2.14.5-1.59.amzn1.noarch
    perl-Git-2.14.5-1.59.amzn1.noarch
    git-bzr-2.14.5-1.59.amzn1.noarch
    git-cvs-2.14.5-1.59.amzn1.noarch
    gitweb-2.14.5-1.59.amzn1.noarch

src:
    git-2.14.5-1.59.amzn1.src

x86_64:
    git-daemon-2.14.5-1.59.amzn1.x86_64
    git-svn-2.14.5-1.59.amzn1.x86_64
    git-2.14.5-1.59.amzn1.x86_64
    git-debuginfo-2.14.5-1.59.amzn1.x86_64