ALAS-2018-1104


Amazon Linux AMI Security Advisory: ALAS-2018-1104
Advisory Release Date: 2018-12-14 01:02 Pacific
Severity: Medium
References: CVE-2018-11763 

Issue Overview:

In Apache HTTP Server 2.4.17 to 2.4.34, by sending continuous, large SETTINGS frames a client can occupy a connection, server thread and CPU time without any connection timeout coming to effect. This affects only HTTP/2 connections. A possible mitigation is to not enable the h2 protocol. (CVE-2018-11763 )


Affected Packages:

httpd24


Issue Correction:
Run yum update httpd24 to update your system.

New Packages:
i686:
    httpd24-tools-2.4.37-1.83.amzn1.i686
    mod24_proxy_html-2.4.37-1.83.amzn1.i686
    httpd24-debuginfo-2.4.37-1.83.amzn1.i686
    httpd24-2.4.37-1.83.amzn1.i686
    mod24_md-2.4.37-1.83.amzn1.i686
    mod24_session-2.4.37-1.83.amzn1.i686
    mod24_ldap-2.4.37-1.83.amzn1.i686
    httpd24-devel-2.4.37-1.83.amzn1.i686
    mod24_ssl-2.4.37-1.83.amzn1.i686

noarch:
    httpd24-manual-2.4.37-1.83.amzn1.noarch

src:
    httpd24-2.4.37-1.83.amzn1.src

x86_64:
    httpd24-tools-2.4.37-1.83.amzn1.x86_64
    httpd24-2.4.37-1.83.amzn1.x86_64
    httpd24-debuginfo-2.4.37-1.83.amzn1.x86_64
    mod24_session-2.4.37-1.83.amzn1.x86_64
    mod24_md-2.4.37-1.83.amzn1.x86_64
    mod24_ssl-2.4.37-1.83.amzn1.x86_64
    httpd24-devel-2.4.37-1.83.amzn1.x86_64
    mod24_ldap-2.4.37-1.83.amzn1.x86_64
    mod24_proxy_html-2.4.37-1.83.amzn1.x86_64