ALAS-2018-938


Amazon Linux AMI Security Advisory: ALAS-2018-938
Advisory Release Date: 2018-01-03 08:22 Pacific
Severity: Medium

Issue Overview:

The NTLM authentication feature in curl and libcurl before 7.57.0 on 32-bit platforms allows attackers to cause a denial of service (integer overflow and resultant buffer overflow, and application crash) or possibly have unspecified other impact via vectors involving long user and password fields. (CVE-2017-8816 )

The FTP wildcard function in curl and libcurl before 7.57.0 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) or possibly have unspecified other impact via a string that ends with an "[" character. (CVE-2017-8817 )


Affected Packages:

curl


Issue Correction:
Run yum update curl to update your system.

New Packages:
i686:
    curl-debuginfo-7.53.1-13.80.amzn1.i686
    curl-7.53.1-13.80.amzn1.i686
    libcurl-7.53.1-13.80.amzn1.i686
    libcurl-devel-7.53.1-13.80.amzn1.i686

src:
    curl-7.53.1-13.80.amzn1.src

x86_64:
    libcurl-7.53.1-13.80.amzn1.x86_64
    curl-7.53.1-13.80.amzn1.x86_64
    libcurl-devel-7.53.1-13.80.amzn1.x86_64
    curl-debuginfo-7.53.1-13.80.amzn1.x86_64