ALAS-2018-943


Amazon Linux AMI Security Advisory: ALAS-2018-943
Advisory Release Date: 2018-01-17 23:18 Pacific
Severity: Medium
References: CVE-2017-1000158 

Issue Overview:

CPython (aka Python) is vulnerable to an integer overflow in the PyString_DecodeEscape function in stringobject.c, resulting in heap-based buffer overflow (and possible arbitrary code execution) (CVE-2017-1000158 )


Affected Packages:

python35,python34


Issue Correction:
Run yum update python35 to update your system.
Run yum update python34 to update your system.

New Packages:
i686:
    python35-test-3.5.4-13.10.amzn1.i686
    python35-3.5.4-13.10.amzn1.i686
    python35-libs-3.5.4-13.10.amzn1.i686
    python35-tools-3.5.4-13.10.amzn1.i686
    python35-debuginfo-3.5.4-13.10.amzn1.i686
    python35-devel-3.5.4-13.10.amzn1.i686
    python34-debuginfo-3.4.7-1.37.amzn1.i686
    python34-devel-3.4.7-1.37.amzn1.i686
    python34-tools-3.4.7-1.37.amzn1.i686
    python34-3.4.7-1.37.amzn1.i686
    python34-test-3.4.7-1.37.amzn1.i686
    python34-libs-3.4.7-1.37.amzn1.i686

src:
    python35-3.5.4-13.10.amzn1.src
    python34-3.4.7-1.37.amzn1.src

x86_64:
    python35-libs-3.5.4-13.10.amzn1.x86_64
    python35-test-3.5.4-13.10.amzn1.x86_64
    python35-tools-3.5.4-13.10.amzn1.x86_64
    python35-debuginfo-3.5.4-13.10.amzn1.x86_64
    python35-devel-3.5.4-13.10.amzn1.x86_64
    python35-3.5.4-13.10.amzn1.x86_64
    python34-tools-3.4.7-1.37.amzn1.x86_64
    python34-debuginfo-3.4.7-1.37.amzn1.x86_64
    python34-3.4.7-1.37.amzn1.x86_64
    python34-libs-3.4.7-1.37.amzn1.x86_64
    python34-devel-3.4.7-1.37.amzn1.x86_64
    python34-test-3.4.7-1.37.amzn1.x86_64