ALAS-2018-948


Amazon Linux AMI Security Advisory: ALAS-2018-948
Advisory Release Date: 2018-02-08 21:32 Pacific
Severity: Low
References: CVE-2017-15298 

Issue Overview:

Mishandling layers of tree objects
Git through 2.14.2 mishandles layers of tree objects, which allows remote attackers to cause a denial of service (memory consumption) via a crafted repository, aka a Git bomb. This can also have an impact of disk consumption; however, an affected process typically would not survive its attempt to build the data structure in memory before writing to disk. (CVE-2017-15298 )


Affected Packages:

git


Issue Correction:
Run yum update git to update your system.

New Packages:
i686:
    git-daemon-2.13.6-2.56.amzn1.i686
    git-debuginfo-2.13.6-2.56.amzn1.i686
    git-svn-2.13.6-2.56.amzn1.i686
    git-2.13.6-2.56.amzn1.i686

noarch:
    git-bzr-2.13.6-2.56.amzn1.noarch
    git-cvs-2.13.6-2.56.amzn1.noarch
    perl-Git-2.13.6-2.56.amzn1.noarch
    git-p4-2.13.6-2.56.amzn1.noarch
    emacs-git-2.13.6-2.56.amzn1.noarch
    emacs-git-el-2.13.6-2.56.amzn1.noarch
    git-email-2.13.6-2.56.amzn1.noarch
    gitweb-2.13.6-2.56.amzn1.noarch
    perl-Git-SVN-2.13.6-2.56.amzn1.noarch
    git-hg-2.13.6-2.56.amzn1.noarch
    git-all-2.13.6-2.56.amzn1.noarch

src:
    git-2.13.6-2.56.amzn1.src

x86_64:
    git-daemon-2.13.6-2.56.amzn1.x86_64
    git-2.13.6-2.56.amzn1.x86_64
    git-debuginfo-2.13.6-2.56.amzn1.x86_64
    git-svn-2.13.6-2.56.amzn1.x86_64