ALAS-2019-1172


Amazon Linux AMI Security Advisory: ALAS-2019-1172
Advisory Release Date: 2019-03-25 23:17 Pacific
Severity: Medium
References: CVE-2019-6486 

Issue Overview:

Go mishandles P-521 and P-384 elliptic curves, which allows attackers to cause a denial of service (CPU consumption) or possibly conduct ECDH private key recovery attacks. (CVE-2019-6486 )


Affected Packages:

golang


Issue Correction:
Run yum update golang to update your system.

New Packages:
i686:
    golang-bin-1.10.6-1.48.amzn1.i686
    golang-1.10.6-1.48.amzn1.i686

noarch:
    golang-src-1.10.6-1.48.amzn1.noarch
    golang-docs-1.10.6-1.48.amzn1.noarch
    golang-tests-1.10.6-1.48.amzn1.noarch
    golang-misc-1.10.6-1.48.amzn1.noarch

src:
    golang-1.10.6-1.48.amzn1.src

x86_64:
    golang-1.10.6-1.48.amzn1.x86_64
    golang-bin-1.10.6-1.48.amzn1.x86_64
    golang-race-1.10.6-1.48.amzn1.x86_64