ALAS-2019-1174


Amazon Linux AMI Security Advisory: ALAS-2019-1174
Advisory Release Date: 2019-03-25 23:11 Pacific
Severity: Low
References: CVE-2019-6978 

Issue Overview:

The GD Graphics Library (aka LibGD) has a double free in the gdImage*Ptr() functions in gd_gif_out.c, gd_jpeg.c, and gd_wbmp.c. NOTE: PHP is unaffected. (CVE-2019-6978 )


Affected Packages:

libwmf


Issue Correction:
Run yum update libwmf to update your system.

New Packages:
i686:
    libwmf-lite-0.2.8.4-41.13.amzn1.i686
    libwmf-devel-0.2.8.4-41.13.amzn1.i686
    libwmf-0.2.8.4-41.13.amzn1.i686
    libwmf-debuginfo-0.2.8.4-41.13.amzn1.i686

src:
    libwmf-0.2.8.4-41.13.amzn1.src

x86_64:
    libwmf-lite-0.2.8.4-41.13.amzn1.x86_64
    libwmf-debuginfo-0.2.8.4-41.13.amzn1.x86_64
    libwmf-devel-0.2.8.4-41.13.amzn1.x86_64
    libwmf-0.2.8.4-41.13.amzn1.x86_64