ALAS-2019-1202


Amazon Linux AMI Security Advisory: ALAS-2019-1202
Advisory Release Date: 2019-05-06 17:48 Pacific
Severity: Important

Issue Overview:

Python is affected by improper Handling of Unicode Encoding (with an incorrect netloc) during NFKC normalization. The impact is information disclosure (credentials, cookies, etc. that are cached against a given hostname). The components are: urllib.parse.urlsplit, urllib.parse.urlparse. The attack vector is: A specially crafted URL could be incorrectly parsed to locate cookies or authentication data and send that information to a different host than when parsed correctly. (CVE-2019-9636 )

Modules/_pickle.c in Python has an integer overflow via a large LONG_BINPUT value that is mishandled during a "resize to twice the size" attempt. This issue might cause memory exhaustion, but is only relevant if the pickle format is used for serializing tens or hundreds of gigabytes of data. (CVE-2018-20406 )


Affected Packages:

python34


Issue Correction:
Run yum update python34 to update your system.

New Packages:
i686:
    python34-devel-3.4.10-1.43.amzn1.i686
    python34-debuginfo-3.4.10-1.43.amzn1.i686
    python34-libs-3.4.10-1.43.amzn1.i686
    python34-tools-3.4.10-1.43.amzn1.i686
    python34-test-3.4.10-1.43.amzn1.i686
    python34-3.4.10-1.43.amzn1.i686

src:
    python34-3.4.10-1.43.amzn1.src

x86_64:
    python34-3.4.10-1.43.amzn1.x86_64
    python34-debuginfo-3.4.10-1.43.amzn1.x86_64
    python34-libs-3.4.10-1.43.amzn1.x86_64
    python34-devel-3.4.10-1.43.amzn1.x86_64
    python34-tools-3.4.10-1.43.amzn1.x86_64
    python34-test-3.4.10-1.43.amzn1.x86_64