ALAS-2019-1204


Amazon Linux AMI Security Advisory: ALAS-2019-1204
Advisory Release Date: 2019-05-30 20:09 Pacific
Severity: Important
References: CVE-2019-9636 

Issue Overview:

Python is affected by improper Handling of Unicode Encoding (with an incorrect netloc) during NFKC normalization. The impact is: Information disclosure (credentials, cookies, etc. that are cached against a given hostname). The components are: urllib.parse.urlsplit, urllib.parse.urlparse. The attack vector is: A specially crafted URL could be incorrectly parsed to locate cookies or authentication data and send that information to a different host than when parsed correctly. (CVE-2019-9636 )


Affected Packages:

python36


Issue Correction:
Run yum update python36 to update your system.

New Packages:
i686:
    python36-debuginfo-3.6.8-1.13.amzn1.i686
    python36-debug-3.6.8-1.13.amzn1.i686
    python36-devel-3.6.8-1.13.amzn1.i686
    python36-tools-3.6.8-1.13.amzn1.i686
    python36-3.6.8-1.13.amzn1.i686
    python36-libs-3.6.8-1.13.amzn1.i686
    python36-test-3.6.8-1.13.amzn1.i686

src:
    python36-3.6.8-1.13.amzn1.src

x86_64:
    python36-devel-3.6.8-1.13.amzn1.x86_64
    python36-libs-3.6.8-1.13.amzn1.x86_64
    python36-3.6.8-1.13.amzn1.x86_64
    python36-tools-3.6.8-1.13.amzn1.x86_64
    python36-debug-3.6.8-1.13.amzn1.x86_64
    python36-test-3.6.8-1.13.amzn1.x86_64
    python36-debuginfo-3.6.8-1.13.amzn1.x86_64