ALAS-2019-1207


Amazon Linux AMI Security Advisory: ALAS-2019-1207
Advisory Release Date: 2019-05-20 18:59 Pacific
Severity: Low
References: CVE-2019-11023 

Issue Overview:

The agroot() function in cgraph\obj.c in libcgraph.a in Graphviz has a NULL pointer dereference, as demonstrated by graphml2gv. (CVE-2019-11023 )


Affected Packages:

graphviz


Issue Correction:
Run yum update graphviz to update your system.

New Packages:
i686:
    graphviz-R-2.38.0-18.51.amzn1.i686
    graphviz-debuginfo-2.38.0-18.51.amzn1.i686
    graphviz-graphs-2.38.0-18.51.amzn1.i686
    graphviz-lua-2.38.0-18.51.amzn1.i686
    graphviz-tcl-2.38.0-18.51.amzn1.i686
    graphviz-python26-2.38.0-18.51.amzn1.i686
    graphviz-java-2.38.0-18.51.amzn1.i686
    graphviz-gd-2.38.0-18.51.amzn1.i686
    graphviz-php54-2.38.0-18.51.amzn1.i686
    graphviz-python27-2.38.0-18.51.amzn1.i686
    graphviz-ruby-2.38.0-18.51.amzn1.i686
    graphviz-2.38.0-18.51.amzn1.i686
    graphviz-doc-2.38.0-18.51.amzn1.i686
    graphviz-perl-2.38.0-18.51.amzn1.i686
    graphviz-guile-2.38.0-18.51.amzn1.i686
    graphviz-devel-2.38.0-18.51.amzn1.i686

src:
    graphviz-2.38.0-18.51.amzn1.src

x86_64:
    graphviz-lua-2.38.0-18.51.amzn1.x86_64
    graphviz-ruby-2.38.0-18.51.amzn1.x86_64
    graphviz-graphs-2.38.0-18.51.amzn1.x86_64
    graphviz-gd-2.38.0-18.51.amzn1.x86_64
    graphviz-2.38.0-18.51.amzn1.x86_64
    graphviz-devel-2.38.0-18.51.amzn1.x86_64
    graphviz-tcl-2.38.0-18.51.amzn1.x86_64
    graphviz-doc-2.38.0-18.51.amzn1.x86_64
    graphviz-guile-2.38.0-18.51.amzn1.x86_64
    graphviz-python27-2.38.0-18.51.amzn1.x86_64
    graphviz-java-2.38.0-18.51.amzn1.x86_64
    graphviz-debuginfo-2.38.0-18.51.amzn1.x86_64
    graphviz-python26-2.38.0-18.51.amzn1.x86_64
    graphviz-R-2.38.0-18.51.amzn1.x86_64
    graphviz-perl-2.38.0-18.51.amzn1.x86_64
    graphviz-php54-2.38.0-18.51.amzn1.x86_64