ALAS-2019-1233


Amazon Linux AMI Security Advisory: ALAS-2019-1233
Advisory Release Date: 2019-07-25 18:33 Pacific
Severity: Low

Issue Overview:

A heap buffer overflow in the TFTP receiving code allows for DoS or arbitrary code execution in libcurl. (CVE-2019-5436 )

An integer overflow in curl's URL API results in a buffer overflow in libcurl. (CVE-2019-5435 )


Affected Packages:

curl


Issue Correction:
Run yum update curl to update your system.

New Packages:
i686:
    curl-debuginfo-7.61.1-11.91.amzn1.i686
    curl-7.61.1-11.91.amzn1.i686
    libcurl-devel-7.61.1-11.91.amzn1.i686
    libcurl-7.61.1-11.91.amzn1.i686

src:
    curl-7.61.1-11.91.amzn1.src

x86_64:
    libcurl-7.61.1-11.91.amzn1.x86_64
    curl-debuginfo-7.61.1-11.91.amzn1.x86_64
    libcurl-devel-7.61.1-11.91.amzn1.x86_64
    curl-7.61.1-11.91.amzn1.x86_64