ALAS-2019-1241


Amazon Linux AMI Security Advisory: ALAS-2019-1241
Advisory Release Date: 2019-07-25 18:41 Pacific
Severity: Medium
References: CVE-2019-11068 

Issue Overview:

libxslt allows bypass of a protection mechanism because callers of xsltCheckRead and xsltCheckWrite permit access even upon receiving a -1 error code. xsltCheckRead can return -1 for a crafted URL that is not actually invalid and is subsequently loaded. (CVE-2019-11068 )


Affected Packages:

libxslt


Issue Correction:
Run yum update libxslt to update your system.

New Packages:
i686:
    libxslt-devel-1.1.28-5.13.amzn1.i686
    libxslt-python27-1.1.28-5.13.amzn1.i686
    libxslt-python26-1.1.28-5.13.amzn1.i686
    libxslt-1.1.28-5.13.amzn1.i686
    libxslt-debuginfo-1.1.28-5.13.amzn1.i686

src:
    libxslt-1.1.28-5.13.amzn1.src

x86_64:
    libxslt-debuginfo-1.1.28-5.13.amzn1.x86_64
    libxslt-python26-1.1.28-5.13.amzn1.x86_64
    libxslt-1.1.28-5.13.amzn1.x86_64
    libxslt-python27-1.1.28-5.13.amzn1.x86_64
    libxslt-devel-1.1.28-5.13.amzn1.x86_64