ALAS-2019-1261


Amazon Linux AMI Security Advisory: ALAS-2019-1261
Advisory Release Date: 2019-08-12 18:23 Pacific
Severity: Medium
References: CVE-2019-3883 

Issue Overview:

1693612:
389-ds-base: DoS via hanging secured connections

It was found that encrypted connections did not honor the 'ioblocktimeout' parameter to end blocking requests. As a result, an unauthenticated attacker could repeatedly start a sufficient number of encrypted connections to block all workers, resulting in a denial of service.(CVE-2019-3883 )


Affected Packages:

389-ds-base


Issue Correction:
Run yum update 389-ds-base to update your system.

New Packages:
i686:
    389-ds-base-devel-1.3.8.4-25.1.62.amzn1.i686
    389-ds-base-libs-1.3.8.4-25.1.62.amzn1.i686
    389-ds-base-debuginfo-1.3.8.4-25.1.62.amzn1.i686
    389-ds-base-1.3.8.4-25.1.62.amzn1.i686
    389-ds-base-snmp-1.3.8.4-25.1.62.amzn1.i686

src:
    389-ds-base-1.3.8.4-25.1.62.amzn1.src

x86_64:
    389-ds-base-snmp-1.3.8.4-25.1.62.amzn1.x86_64
    389-ds-base-devel-1.3.8.4-25.1.62.amzn1.x86_64
    389-ds-base-1.3.8.4-25.1.62.amzn1.x86_64
    389-ds-base-libs-1.3.8.4-25.1.62.amzn1.x86_64
    389-ds-base-debuginfo-1.3.8.4-25.1.62.amzn1.x86_64