ALAS-2019-1287


Amazon Linux AMI Security Advisory: ALAS-2019-1287
Advisory Release Date: 2019-09-18 21:38 Pacific
Severity: Medium
References: CVE-2018-12015 

Issue Overview:

It was found that the Archive::Tar module did not properly sanitize symbolic links when extracting tar archives. An attacker, able to provide a specially crafted archive for processing, could use this flaw to write or overwrite arbitrary files in the context of the Perl interpreter.(CVE-2018-12015 )


Affected Packages:

perl-Archive-Tar


Issue Correction:
Run yum update perl-Archive-Tar to update your system.

New Packages:
noarch:
    perl-Archive-Tar-1.92-3.6.amzn1.noarch

src:
    perl-Archive-Tar-1.92-3.6.amzn1.src