ALAS-2019-1312


Amazon Linux AMI Security Advisory: ALAS-2019-1312
Advisory Release Date: 2019-11-07 00:22 Pacific
Severity: Important

Issue Overview:

do_ed_script in pch.c in GNU patch through 2.7.6 does not block strings beginning with a ! character. NOTE: this is the same commit as for CVE-2019-13638 , but the ! syntax is specific to ed, and is unrelated to a shell metacharacter.(CVE-2018-20969 )

GNU patch through 2.7.6 is vulnerable to OS shell command injection that can be exploited by opening a crafted patch file that contains an ed style diff payload with shell metacharacters. The ed editor does not need to be present on the vulnerable system. This is different from CVE-2018-1000156 . (CVE-2019-13638 )

A heap-based out-of-bounds read flaw was found in the way the patch utility parsed patch files. An attacker could potentially use this flaw to crash the patch utility by tricking it into processing crafted patch files.(CVE-2016-10713 )

A double-free flaw was found in the way the patch utility processed patch files. An attacker could potentially use this flaw to crash the patch utility by tricking it into processing crafted patches.(CVE-2018-6952 )


Affected Packages:

patch


Issue Correction:
Run yum update patch to update your system.

New Packages:
i686:
    patch-2.7.1-12.14.amzn1.i686
    patch-debuginfo-2.7.1-12.14.amzn1.i686

src:
    patch-2.7.1-12.14.amzn1.src

x86_64:
    patch-2.7.1-12.14.amzn1.x86_64
    patch-debuginfo-2.7.1-12.14.amzn1.x86_64