ALAS-2019-1321


Amazon Linux AMI Security Advisory: ALAS-2019-1321
Advisory Release Date: 2019-11-22 03:21 Pacific
Severity: Medium
References: CVE-2019-16276 

Issue Overview:

It was discovered that net/http (through net/textproto) in golang does not correctly interpret HTTP requests where an HTTP header contains spaces before the colon. This could be abused by an attacker to smuggle HTTP requests when a proxy or a firewall is placed behind a server implemented in Go or to filter bypasses depending on the specific network configuration. (CVE-2019-16276 )


Affected Packages:

golang


Issue Correction:
Run yum update golang to update your system.

New Packages:
i686:
    golang-bin-1.12.8-1.52.amzn1.i686
    golang-1.12.8-1.52.amzn1.i686

noarch:
    golang-misc-1.12.8-1.52.amzn1.noarch
    golang-src-1.12.8-1.52.amzn1.noarch
    golang-tests-1.12.8-1.52.amzn1.noarch
    golang-docs-1.12.8-1.52.amzn1.noarch

src:
    golang-1.12.8-1.52.amzn1.src

x86_64:
    golang-1.12.8-1.52.amzn1.x86_64
    golang-race-1.12.8-1.52.amzn1.x86_64
    golang-bin-1.12.8-1.52.amzn1.x86_64