ALAS-2020-1348


Amazon Linux AMI Security Advisory: ALAS-2020-1348
Advisory Release Date: 2020-03-13 19:43 Pacific
Severity: Medium

Issue Overview:

FreeType before 2.6.1 has a heap-based buffer over-read in T1_Get_Private_Dict in type1/t1parse.c. (CVE-2015-9381 )

FreeType before 2.6.1 has a buffer over-read in skip_comment in psaux/psobjs.c because ps_parser_skip_PS_token is mishandled in an FT_New_Memory_Face operation. (CVE-2015-9382 )


Affected Packages:

freetype


Issue Correction:
Run yum update freetype to update your system.

New Packages:
i686:
    freetype-2.3.11-19.15.amzn1.i686
    freetype-debuginfo-2.3.11-19.15.amzn1.i686
    freetype-demos-2.3.11-19.15.amzn1.i686
    freetype-devel-2.3.11-19.15.amzn1.i686

src:
    freetype-2.3.11-19.15.amzn1.src

x86_64:
    freetype-demos-2.3.11-19.15.amzn1.x86_64
    freetype-devel-2.3.11-19.15.amzn1.x86_64
    freetype-2.3.11-19.15.amzn1.x86_64
    freetype-debuginfo-2.3.11-19.15.amzn1.x86_64