ALAS-2020-1373


Amazon Linux AMI Security Advisory: ALAS-2020-1373
Advisory Release Date: 2020-05-22 20:58 Pacific
Advisory Updated Date: 2020-06-03 17:22 Pacific
Severity: Important

Issue Overview:

A network amplification vulnerability was found in Unbound, in the way it processes delegation messages from one authoritative zone to another. This flaw allows an attacker to cause a denial of service or be part of an attack against another DNS server when Unbound is deployed as a recursive resolver or authoritative name server.(CVE-2020-12662 )

Unbound before 1.10.1 has an infinite loop via malformed DNS answers received from upstream servers.(CVE-2020-12663 )


Affected Packages:

unbound


Issue Correction:
Run yum update unbound to update your system.

New Packages:
i686:
    unbound-1.6.6-1.5.amzn1.i686
    unbound-libs-1.6.6-1.5.amzn1.i686
    unbound-debuginfo-1.6.6-1.5.amzn1.i686
    unbound-devel-1.6.6-1.5.amzn1.i686
    unbound-python-1.6.6-1.5.amzn1.i686

src:
    unbound-1.6.6-1.5.amzn1.src

x86_64:
    unbound-devel-1.6.6-1.5.amzn1.x86_64
    unbound-debuginfo-1.6.6-1.5.amzn1.x86_64
    unbound-libs-1.6.6-1.5.amzn1.x86_64
    unbound-python-1.6.6-1.5.amzn1.x86_64
    unbound-1.6.6-1.5.amzn1.x86_64