ALAS-2020-1374


Amazon Linux AMI Security Advisory: ALAS-2020-1374
Advisory Release Date: 2020-06-03 17:22 Pacific
Severity: Medium
References: CVE-2018-20217 

Issue Overview:

A Reachable Assertion issue was discovered in the KDC in MIT Kerberos 5 (aka krb5) before 1.17. If an attacker can obtain a krbtgt ticket using an older encryption type (single-DES, triple-DES, or RC4), the attacker can crash the KDC by making an S4U2Self request.(CVE-2018-20217 )


Affected Packages:

krb5


Issue Correction:
Run yum update krb5 to update your system.

New Packages:
i686:
    krb5-debuginfo-1.15.1-46.48.amzn1.i686
    krb5-devel-1.15.1-46.48.amzn1.i686
    libkadm5-1.15.1-46.48.amzn1.i686
    krb5-server-ldap-1.15.1-46.48.amzn1.i686
    krb5-server-1.15.1-46.48.amzn1.i686
    krb5-workstation-1.15.1-46.48.amzn1.i686
    krb5-pkinit-openssl-1.15.1-46.48.amzn1.i686
    krb5-libs-1.15.1-46.48.amzn1.i686

src:
    krb5-1.15.1-46.48.amzn1.src

x86_64:
    krb5-workstation-1.15.1-46.48.amzn1.x86_64
    krb5-libs-1.15.1-46.48.amzn1.x86_64
    libkadm5-1.15.1-46.48.amzn1.x86_64
    krb5-server-ldap-1.15.1-46.48.amzn1.x86_64
    krb5-server-1.15.1-46.48.amzn1.x86_64
    krb5-devel-1.15.1-46.48.amzn1.x86_64
    krb5-pkinit-openssl-1.15.1-46.48.amzn1.x86_64
    krb5-debuginfo-1.15.1-46.48.amzn1.x86_64