ALAS-2020-1394


Amazon Linux AMI Security Advisory: ALAS-2020-1394
Advisory Release Date: 2020-07-15 17:29 Pacific
Severity: Medium
References: CVE-2019-18609 

Issue Overview:

An issue was discovered in amqp_handle_input in amqp_connection.c in rabbitmq-c 0.9.0. There is an integer overflow that leads to heap memory corruption in the handling of CONNECTION_STATE_HEADER. A rogue server could return a malicious frame header that leads to a smaller target_size value than needed. This condition is then carried on to a memcpy function that copies too much data into a heap buffer. (CVE-2019-18609 )


Affected Packages:

librabbitmq


Issue Correction:
Run yum update librabbitmq to update your system.

New Packages:
i686:
    librabbitmq-devel-0.1-0.2.hgfb6fca832fd2.3.amzn1.i686
    librabbitmq-debuginfo-0.1-0.2.hgfb6fca832fd2.3.amzn1.i686
    librabbitmq-0.1-0.2.hgfb6fca832fd2.3.amzn1.i686

src:
    librabbitmq-0.1-0.2.hgfb6fca832fd2.3.amzn1.src

x86_64:
    librabbitmq-devel-0.1-0.2.hgfb6fca832fd2.3.amzn1.x86_64
    librabbitmq-debuginfo-0.1-0.2.hgfb6fca832fd2.3.amzn1.x86_64
    librabbitmq-0.1-0.2.hgfb6fca832fd2.3.amzn1.x86_64