ALAS-2020-1406


Amazon Linux AMI Security Advisory: ALAS-2020-1406
Advisory Release Date: 2020-07-27 23:54 Pacific
Advisory Updated Date: 2020-07-29 21:38 Pacific
Severity: Medium
References: CVE-2020-8492 

Issue Overview:

Python 2.7 through 2.7.17, 3.5 through 3.5.9, 3.6 through 3.6.10, 3.7 through 3.7.6, and 3.8 through 3.8.1 allows an HTTP server to conduct Regular Expression Denial of Service (ReDoS) attacks against a client because of urllib.request.AbstractBasicAuthHandler catastrophic backtracking. (CVE-2020-8492 )


Affected Packages:

python26


Issue Correction:
Run yum update python26 to update your system.

New Packages:
i686:
    python26-2.6.9-2.90.amzn1.i686
    python26-debuginfo-2.6.9-2.90.amzn1.i686
    python26-devel-2.6.9-2.90.amzn1.i686
    python26-libs-2.6.9-2.90.amzn1.i686
    python26-test-2.6.9-2.90.amzn1.i686
    python26-tools-2.6.9-2.90.amzn1.i686

src:
    python26-2.6.9-2.90.amzn1.src

x86_64:
    python26-debuginfo-2.6.9-2.90.amzn1.x86_64
    python26-devel-2.6.9-2.90.amzn1.x86_64
    python26-test-2.6.9-2.90.amzn1.x86_64
    python26-2.6.9-2.90.amzn1.x86_64
    python26-tools-2.6.9-2.90.amzn1.x86_64
    python26-libs-2.6.9-2.90.amzn1.x86_64