ALAS-2020-1438


Amazon Linux AMI Security Advisory: ALAS-2020-1438
Advisory Release Date: 2020-10-26 18:09 Pacific
Advisory Updated Date: 2020-10-27 21:22 Pacific
Severity: Medium

Issue Overview:

xmlParseBalancedChunkMemoryRecover in parser.c in libxml2 before 2.9.10 has a memory leak related to newDoc->oldNs. (CVE-2019-19956 )

A memory leak was found in the xmlSchemaValidateStream function of libxml2. Applications that use this library may be vulnerable to memory not being freed leading to a denial of service. System availability is the highest threat from this vulnerability. (CVE-2019-20388 )

xmlStringLenDecodeEntities in parser.c in libxml2 2.9.10 has an infinite loop in a certain end-of-file situation. (CVE-2020-7595 )


Affected Packages:

libxml2


Issue Correction:
Run yum update libxml2 to update your system.

New Packages:
i686:
    libxml2-debuginfo-2.9.1-6.4.41.amzn1.i686
    libxml2-python26-2.9.1-6.4.41.amzn1.i686
    libxml2-python27-2.9.1-6.4.41.amzn1.i686
    libxml2-devel-2.9.1-6.4.41.amzn1.i686
    libxml2-static-2.9.1-6.4.41.amzn1.i686
    libxml2-2.9.1-6.4.41.amzn1.i686

src:
    libxml2-2.9.1-6.4.41.amzn1.src

x86_64:
    libxml2-python26-2.9.1-6.4.41.amzn1.x86_64
    libxml2-devel-2.9.1-6.4.41.amzn1.x86_64
    libxml2-debuginfo-2.9.1-6.4.41.amzn1.x86_64
    libxml2-python27-2.9.1-6.4.41.amzn1.x86_64
    libxml2-static-2.9.1-6.4.41.amzn1.x86_64
    libxml2-2.9.1-6.4.41.amzn1.x86_64