ALAS-2020-1450


Amazon Linux AMI Security Advisory: ALAS-2020-1450
Advisory Release Date: 2020-11-14 01:23 Pacific
Advisory Updated Date: 2020-11-16 20:49 Pacific
Severity: Low
References: CVE-2019-14494 

Issue Overview:

A divide-by-zero error was found in the way Poppler handled certain PDF files. A remote attacker could exploit this flaw by providing a malicious PDF file that, when processed by an application linked to Poppler, would crash the application causing a denial of service. (CVE-2019-14494 )


Affected Packages:

poppler


Issue Correction:
Run yum update poppler to update your system.

New Packages:
i686:
    poppler-0.26.5-43.22.amzn1.i686
    poppler-utils-0.26.5-43.22.amzn1.i686
    poppler-devel-0.26.5-43.22.amzn1.i686
    poppler-glib-devel-0.26.5-43.22.amzn1.i686
    poppler-cpp-0.26.5-43.22.amzn1.i686
    poppler-debuginfo-0.26.5-43.22.amzn1.i686
    poppler-glib-0.26.5-43.22.amzn1.i686
    poppler-cpp-devel-0.26.5-43.22.amzn1.i686

src:
    poppler-0.26.5-43.22.amzn1.src

x86_64:
    poppler-0.26.5-43.22.amzn1.x86_64
    poppler-glib-0.26.5-43.22.amzn1.x86_64
    poppler-utils-0.26.5-43.22.amzn1.x86_64
    poppler-glib-devel-0.26.5-43.22.amzn1.x86_64
    poppler-cpp-0.26.5-43.22.amzn1.x86_64
    poppler-debuginfo-0.26.5-43.22.amzn1.x86_64
    poppler-devel-0.26.5-43.22.amzn1.x86_64
    poppler-cpp-devel-0.26.5-43.22.amzn1.x86_64