ALAS-2021-1462


Amazon Linux AMI Security Advisory: ALAS-2021-1462
Advisory Release Date: 2021-01-12 22:51 Pacific
Advisory Updated Date: 2021-01-13 18:15 Pacific
Severity: Important
References: CVE-2020-14363 

Issue Overview:

An integer overflow vulnerability leading to a double-free was found in libX11. This flaw allows a local privileged attacker to cause an application compiled with libX11 to crash, or in some cases, result in arbitrary code execution. The highest threat from this flaw is to confidentiality, integrity as well as system availability. (CVE-2020-14363 )


Affected Packages:

libX11


Issue Correction:
Run yum update libX11 to update your system.

New Packages:
i686:
    libX11-common-1.6.0-2.2.13.amzn1.i686
    libX11-devel-1.6.0-2.2.13.amzn1.i686
    libX11-1.6.0-2.2.13.amzn1.i686
    libX11-debuginfo-1.6.0-2.2.13.amzn1.i686

src:
    libX11-1.6.0-2.2.13.amzn1.src

x86_64:
    libX11-1.6.0-2.2.13.amzn1.x86_64
    libX11-common-1.6.0-2.2.13.amzn1.x86_64
    libX11-debuginfo-1.6.0-2.2.13.amzn1.x86_64
    libX11-devel-1.6.0-2.2.13.amzn1.x86_64