ALAS-2021-1471


Amazon Linux AMI Security Advisory: ALAS-2021-1471
Advisory Release Date: 2021-01-12 22:52 Pacific
Advisory Updated Date: 2021-01-13 18:27 Pacific
Severity: Medium

Issue Overview:

Go before 1.14.12 and 1.15.x before 1.15.4 allows Denial of Service. (CVE-2020-28362 )

Go before 1.14.12 and 1.15.x before 1.15.5 allows Code Injection. (CVE-2020-28366 )

Go before 1.14.12 and 1.15.x before 1.15.5 allows Argument Injection. (CVE-2020-28367 )


Affected Packages:

golang


Issue Correction:
Run yum update golang to update your system.

New Packages:
i686:
    golang-bin-1.15.5-1.65.amzn1.i686
    golang-1.15.5-1.65.amzn1.i686

noarch:
    golang-docs-1.15.5-1.65.amzn1.noarch
    golang-misc-1.15.5-1.65.amzn1.noarch
    golang-tests-1.15.5-1.65.amzn1.noarch
    golang-src-1.15.5-1.65.amzn1.noarch

src:
    golang-1.15.5-1.65.amzn1.src

x86_64:
    golang-bin-1.15.5-1.65.amzn1.x86_64
    golang-1.15.5-1.65.amzn1.x86_64
    golang-race-1.15.5-1.65.amzn1.x86_64