ALAS-2021-1473


Amazon Linux AMI Security Advisory: ALAS-2021-1473
Advisory Release Date: 2021-01-12 22:52 Pacific
Advisory Updated Date: 2021-01-13 18:29 Pacific
Severity: Medium
References: CVE-2020-17527 

Issue Overview:

While investigating bug 64830 it was discovered that Apache Tomcat 10.0.0-M1 to 10.0.0-M9, 9.0.0-M1 to 9.0.39 and 8.5.0 to 8.5.59 could re-use an HTTP request header value from the previous stream received on an HTTP/2 connection for the request associated with the subsequent stream. While this would most likely lead to an error and the closure of the HTTP/2 connection, it is possible that information could leak between requests. (CVE-2020-17527 )


Affected Packages:

tomcat8


Issue Correction:
Run yum update tomcat8 to update your system.

New Packages:
noarch:
    tomcat8-admin-webapps-8.5.60-1.86.amzn1.noarch
    tomcat8-lib-8.5.60-1.86.amzn1.noarch
    tomcat8-log4j-8.5.60-1.86.amzn1.noarch
    tomcat8-jsp-2.3-api-8.5.60-1.86.amzn1.noarch
    tomcat8-javadoc-8.5.60-1.86.amzn1.noarch
    tomcat8-webapps-8.5.60-1.86.amzn1.noarch
    tomcat8-el-3.0-api-8.5.60-1.86.amzn1.noarch
    tomcat8-servlet-3.1-api-8.5.60-1.86.amzn1.noarch
    tomcat8-docs-webapp-8.5.60-1.86.amzn1.noarch
    tomcat8-8.5.60-1.86.amzn1.noarch

src:
    tomcat8-8.5.60-1.86.amzn1.src