ALAS-2021-1474


Amazon Linux AMI Security Advisory: ALAS-2021-1474
Advisory Release Date: 2021-01-12 22:52 Pacific
Advisory Updated Date: 2021-01-13 18:29 Pacific
Severity: Medium
References: CVE-2019-20807 

Issue Overview:

A flaw was found in vim in the restricted mode, where all commands that make use of external shells are disabled. However, it was found that users could still execute some arbitrary OS commands in the restricted mode. This flaw was fixed by filtering the functions that can call OS commands. Interfaces such as Python, Ruby, and Lua, are also disabled, as they can be used to execute shell commands. Perl uses the Safe module. (CVE-2019-20807 )


Affected Packages:

vim


Issue Correction:
Run yum update vim to update your system.

New Packages:
i686:
    vim-enhanced-8.0.0503-1.47.amzn1.i686
    vim-common-8.0.0503-1.47.amzn1.i686
    vim-minimal-8.0.0503-1.47.amzn1.i686
    vim-debuginfo-8.0.0503-1.47.amzn1.i686
    vim-filesystem-8.0.0503-1.47.amzn1.i686

src:
    vim-8.0.0503-1.47.amzn1.src

x86_64:
    vim-minimal-8.0.0503-1.47.amzn1.x86_64
    vim-debuginfo-8.0.0503-1.47.amzn1.x86_64
    vim-filesystem-8.0.0503-1.47.amzn1.x86_64
    vim-common-8.0.0503-1.47.amzn1.x86_64
    vim-enhanced-8.0.0503-1.47.amzn1.x86_64